FaName 1.0 - 'page.php?name' Cross-Site Scripting

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1115587 漏洞类型 Input Validation Error
发布时间 2008-06-30 更新时间 2008-07-08
CVE编号 CVE-2007-3653 CNNVD-ID N/A
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/32005
https://www.securityfocus.com/bid/81670
|漏洞详情
This vulnerability has been modified since it was last analyzed by the NVD. It is awaiting reanalysis which may result in further changes to the information provided.
|漏洞EXP
source: http://www.securityfocus.com/bid/30019/info
 
FaName is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input.
 
An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks
 
FaName 1.0 is vulnerable; other versions may also be affected. 

http://www.example.com/[FANAME-DIRECTORY]/page.php?name=<script>alert(document.cookies)</script>
|受影响的产品
FaScript FaName 1.0
|参考资料
resource:
hyperlink:http://www.netvigilance.com/advisory0043
resource:
hyperlink:https://exchange.xforce.ibmcloud.com/vulnerabilities/43502