1Scripts Z1Exchange 'showads.php'跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1116910 漏洞类型 跨站脚本
发布时间 2008-12-02 更新时间 2009-03-03
CVE编号 CVE-2008-6386 CNNVD-ID CNNVD-200903-040
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/32634
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200903-040
|漏洞详情
Z1Exchange是一个免费的脚本允许你创建自己的广告文字链接交换网络。Z1Exchange1.0版本的showads.php中存在跨站脚本攻击漏洞。远程攻击者可以借助id参数,注入任意web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/32598/info
 
Z1Exchange is prone to an SQL-injection vulnerability and a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.
 
Exploiting these issues could allow an attacker to steal cookie-based authentication credentials, compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.
 
Z1Exchange 1.0 is vulnerable; other versions may also be affected. 

http://www.example.com/[Path]/showads.php?id=<script>alert(1369)</script>
|参考资料

来源:XF
名称:z1exchange-showads-xss(47028)
链接:http://xforce.iss.net/xforce/xfdb/47028
来源:MISC
链接:http://packetstormsecurity.org/0812-exploits/z1exchange-sqlxss.txt