AOLserver 非打印字符溢出序列的HTTP请求执行任意文件和重写漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1118900 漏洞类型 输入验证
发布时间 2010-01-11 更新时间 2010-01-11
CVE编号 CVE-2009-4494 CNNVD-ID CNNVD-201001-103
漏洞平台 Multiple CVSS评分 5.0
|漏洞来源
https://www.exploit-db.com/exploits/33497
https://www.securityfocus.com/bid/37712
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201001-103
|漏洞详情
AOLserver4.5.1版本可以向具有一个没有审查过的非打印字符的登录文件写入数据,这可能会允许远程攻击者借助一个包含终极模拟器的一个溢出序列的HTTP请求,修改一个窗口的标题或可能执行任意执行并重写文件。
|漏洞EXP
source: http://www.securityfocus.com/bid/37712/info

AOLServer is prone to a command-injection vulnerability because it fails to adequately sanitize user-supplied input in logfiles.

Attackers can exploit this issue to execute arbitrary commands in a terminal.

AOLServer 4.5.1 is vulnerable; other versions may also be affected.

The following example is available:

echo -en "GET /\x1b]2;owned?\x07\x0a\x0d\x0a\x0d" > payload
nc www.example.com 80 < payload
|受影响的产品
AOL AOLserver 4.5.1 AOL AOLserver 4.0 .beta1 AOL AOLserver 3.4.2 Win32 - Microsoft Windows 2000 Advanced Server SP2 - Microsoft Windo
|参考资料

来源:MISC
链接:http://www.ush.it/team/ush/hack_httpd_escape/adv.txt
来源:BID
名称:37712
链接:http://www.securityfocus.com/bid/37712
来源:BUGTRAQ
名称:20100110Nginx,Varnish,Cherokee,thttpd,mini-httpd,WEBrick,Orion,AOLserver,YawsandBoalogescapesequenceinjection
链接:http://www.securityfocus.com/archive/1/archive/1/508830/100/0/threaded