PHP Intl扩展NumberFormatter::setSymbol函数拒绝服务漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1120327 漏洞类型 Unknown
发布时间 2011-03-10 更新时间 2012-04-17
CVE编号 CVE-2011-1467 CNNVD-ID CNNVD-201103-261
漏洞平台 PHP CVSS评分 5.0
|漏洞来源
https://www.exploit-db.com/exploits/35483
https://www.securityfocus.com/bid/46968
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201103-261
|漏洞详情
PHP(PHP:HypertextPreprocessor,PHP:超文本预处理器)是PHPGroup和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。PHP5.3.6之前版本中的Intl扩展中的NumberFormatter::setSymbol(又名numfmt_set_symbol)函数中存在未明漏洞。上下文攻击者可以借助无效参数导致拒绝服务(应用程序崩溃)。
|漏洞EXP
source: http://www.securityfocus.com/bid/46968/info

PHP is prone to a remote denial-of-service vulnerability that affects the 'Intl' extension.

Successful attacks will cause the application to crash, creating a denial-of-service condition. Due to the nature of this issue, arbitrary code-execution may be possible; however, this has not been confirmed.

PHP versions prior to 5.3.6 are vulnerable.

numfmt_set_symbol(numfmt_create("en", NumberFormatter::PATTERN_DECIMAL), 2147483648, "")
|受影响的产品
Ubuntu Ubuntu Linux 9.10 sparc Ubuntu Ubuntu Linux 9.10 powerpc Ubuntu Ubuntu Linux 9.10 lpia Ubuntu Ubuntu Linux 9.10 i386 Ubuntu Ubuntu Linux 9.10 ARM Ubuntu Ubuntu Lin
|参考资料

来源:www.php.net
链接:http://www.php.net/ChangeLog-5.php
来源:bugs.php.net
链接:http://bugs.php.net/bug.php?id=53512
来源:NSFOCUS
名称:16624
链接:http://www.nsfocus.net/vulndb/16624