ARM mbed TLS 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1127149 漏洞类型 缓冲区错误
发布时间 2018-04-11 更新时间 2019-10-08
CVE编号 CVE-2018-9989 CNNVD-ID CNNVD-201804-460
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201804-460
|漏洞详情
ARM mbed TLS(前称PolarSSL)是英国ARM公司的一款为mbed产品提供安全通讯和加密功能的产品。 ARM mbed TLS 2.1.11之前版本、2.7.2之前版本和2.8.0之前版本中的‘ssl_parse_server_psk_hint()’函数存在缓冲区越边界读取漏洞。攻击者可利用该漏洞造成拒绝服务(崩溃)。
|参考资料

来源:github.com
链接:https://github.com/ARMmbed/mbedtls/commit/5224a7544c95552553e2e6be0b4a789956a6464e
来源:github.com
链接:https://github.com/ARMmbed/mbedtls/commit/740b218386083dc708ce98ccc94a63a95cd5629e
来源:tls.mbed.org
链接:https://tls.mbed.org/tech-updates/releases/mbedtls-2.8.0-2.7.2-and-2.1.11-released