Ruby Loofah gem 跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1127693 漏洞类型 跨站脚本
发布时间 2018-03-28 更新时间 2019-11-25
CVE编号 CVE-2018-8048 CNNVD-ID CNNVD-201803-956
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201803-956
|漏洞详情
Ruby Loofah gem是一个用于操作和转换HTML/XML文档的通用库。 Ruby Loofah gem 2.2.0及之前版本中存在跨站脚本漏洞。远程攻击者可通过重新发布特制的HTML片段利用该漏洞使非白名单HTML属性显示在已过滤的输出中。
|参考资料

来源:MLIST
链接:http://www.openwall.com/lists/oss-security/2018/03/19/5
来源:CONFIRM
链接:https://github.com/flavorjones/loofah/issues/144