RubyGems 跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1128262 漏洞类型 跨站脚本
发布时间 2018-03-13 更新时间 2020-03-05
CVE编号 CVE-2018-1000078 CNNVD-ID CNNVD-201803-409
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201803-409
|漏洞详情
RubyGems是RubyGems组织的一款Ruby程序包管理器,它主要用于发布和管理Ruby程序包。 RubyGems中的主页属性存在跨站脚本漏洞,该漏洞源于程序没有正确的校验用户提交的输入。远程攻击者可借助特制的URL利用该漏洞在用户浏览器中执行脚本。以下版本受到影响:RubyGems 2.2.9版本,2.3.6版本,2.4.3版本,2.5.0版本。
|参考资料

来源:MISC
链接:http://blog.rubygems.org/2018/02/15/2.7.6-released.html
来源:MISC
链接:https://github.com/rubygems/rubygems/commit/66a28b9275551384fdab45f3591a82d6b59952cb