Twitter Kit for iOS Login with Twitter组件安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1129172 漏洞类型 授权问题
发布时间 2018-02-11 更新时间 2019-10-17
CVE编号 CVE-2017-0911 CNNVD-ID CNNVD-201802-334
漏洞平台 N/A CVSS评分 5.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201802-334
|漏洞详情
Twitter Kit for iOS是一套基于iOS平台的开源的用于与Twitter进行无缝交互的本地开发工具包。Login with Twitter component是其中的一个登陆组件。 基于iOS平台的Twitter Kit 3.0版本至3.2.1版本中的Login with Twitter组件存在安全漏洞。攻击者可利用该漏洞提交代替性的凭证,使推特账户与第三方服务发生关联。
|参考资料

来源:CONFIRM
链接:https://blog.twitter.com/developer/en_us/topics/tips/2018/vulnerability-in-twitter-kit-for-ios.html
来源:CONFIRM
链接:https://github.com/twitter/twitter-kit-ios/blob/b6eb49d149b056d826cbc4b53eaeb39a3ebd591e/TwitterKit/TwitterKit/Social/Identity/TWTRMobileSSO.m#L71
来源:CONFIRM
链接:https://github.com/twitter/twitter-kit-ios/blob/b6eb49d149b056d826cbc4b53eaeb39a3ebd591e/TwitterKit/TwitterKit/TWTRTwitter.m#L411
来源:CONFIRM
链接:https://github.com/twitter/twitter-kit-ios/wiki/Changelog#322-november-28-2017
来源:MISC
链接:https://hackerone.com/reports/290229