Jerome Gamez Firebase Admin SDK for PHP 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1129193 漏洞类型
发布时间 2018-02-11 更新时间 2019-10-23
CVE编号 CVE-2018-1000025 CNNVD-ID CNNVD-201802-312
漏洞平台 N/A CVSS评分 6.8
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201802-312
|漏洞详情
Jerome Gamez Firebase Admin SDK for PHP是一套基于PHP的软件开发工具包。 Jerome Gamez Firebase Admin SDK for PHP 3.2.0版本至3.8.0版本中的src/Firebase/Auth/IdTokenVerifier.php文件存在访问控制错误漏洞,该漏洞源于程序没有验证令牌签名。攻击者可利用该漏洞伪造带有任意邮件地址和用户ID的JSON Web Token(JWT)。
|参考资料

来源:CONFIRM
链接:https://github.com/kreait/firebase-php/pull/151
来源:CONFIRM
链接:https://github.com/kreait/firebase-php/releases/tag/3.8.1