GNU Libgcrypt 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1129295 漏洞类型 加密问题
发布时间 2018-02-08 更新时间 2020-01-19
CVE编号 CVE-2018-6829 CNNVD-ID CNNVD-201802-189
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201802-189
|漏洞详情
Libgcrypt是GNU计划开发的一个基于GnuPG代码的通用加密库。该库实现了各种加密算法,包括对称密码、哈希算法、公开密钥算法等。 GNU Libgcrypt 1.8.2及之前版本中的cipher/elgamal.c文件存在加密问题漏洞。攻击者可通过读取密文数据利用该漏洞获取敏感信息。
|参考资料

来源:MISC
链接:https://github.com/weikengchen/attack-on-libgcrypt-elgamal
来源:MISC
链接:https://github.com/weikengchen/attack-on-libgcrypt-elgamal/wiki
来源:MISC
链接:https://lists.gnupg.org/pipermail/gcrypt-devel/2018-February/004394.html