Parsec 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1129412 漏洞类型 跨站请求伪造
发布时间 2018-02-06 更新时间 2019-10-10
CVE编号 CVE-2018-6651 CNNVD-ID CNNVD-201802-092
漏洞平台 N/A CVSS评分 9.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201802-092
|漏洞详情
Parsec是一个多线程应用程序组成的测试程序集。uncurl是一款基于C语言的HTTP/HTTPS客户端库。 Parsec 140-3之前版本中的uncurl 0.07之前版本的uncurl.c文件的‘uncurl_ws_accept’函数存在安全漏洞,该漏洞源于程序没有对WebSocket API请求执行充分的源包头检测。远程攻击者可利用该漏洞绕过访问限制。
|参考资料

来源:CONFIRM
链接:https://github.com/chrisd1100/uncurl/commit/448cd13e7b18c83855d706c564341ddd1e38e769
来源:CONFIRM
链接:https://github.com/chrisd1100/uncurl/releases/tag/0.07