libwebm 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1129533 漏洞类型 缓冲区错误
发布时间 2018-01-31 更新时间 2019-10-23
CVE编号 CVE-2018-6406 CNNVD-ID CNNVD-201801-1074
漏洞平台 N/A CVSS评分 6.8
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201801-1074
|漏洞详情
libwebm是一个开源的网络媒体文件编解码库。 libwebm 2018-01-30及之前版本中的common/libwebm_util.cc文件的‘ParseVP9SuperFrameIndex’函数存在安全漏洞,该漏洞源于程序没有验证.webm文件的child_frame_length数据。远程攻击者可利用该漏洞泄露信息或造成拒绝服务(基于堆的缓冲区越边界读取和越边界写入)。
|参考资料

来源:MISC
链接:https://bugs.chromium.org/p/webm/issues/detail?id=1492
来源:MISC
链接:https://github.com/dwfault/PoCs/blob/master/libwebm%20ParseVP9SuperFrameIndex%20memory%20corruption/libwebm%20ParseVP9SuperFrameIndex%20OOB%20read.md