Haxx libcurl 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1129677 漏洞类型 缓冲区错误
发布时间 2018-01-25 更新时间 2019-06-25
CVE编号 CVE-2018-1000005 CNNVD-ID CNNVD-201801-903
漏洞平台 N/A CVSS评分 6.4
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201801-903
|漏洞详情
Haxx libcurl是瑞典Haxx公司的一个免费、开源的客户端URL传输库。该库支持FTP、FTPS、TFTP、HTTP等。 Haxx libcurl 7.49.0版本至7.57.0版本中的code handling HTTP/2 trailers存在安全漏洞。攻击者可利用该漏洞获取信息或造成拒绝服务(越边界读取或崩溃)。
|参考资料

来源:CONFIRM
链接:https://curl.haxx.se/docs/adv_2018-824a.html
来源:CONFIRM
链接:https://github.com/curl/curl/pull/2231