GraphicsMagick 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1131011 漏洞类型 缓冲区错误
发布时间 2017-12-12 更新时间 2019-07-02
CVE编号 CVE-2017-17502 CNNVD-ID CNNVD-201712-353
漏洞平台 N/A CVSS评分 6.8
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201712-353
|漏洞详情
GraphicsMagick是一套简单的图像处理工具。该工具对图像提供尺寸调整、旋转、加亮等功能。 GraphicsMagick 1.3.26版本中的coders/cmyk.c文件的‘ReadCMYKImage’函数和magick/import.c文件的‘ImportCMYKQuantumType’函数存在堆缓冲区溢出漏洞。攻击者可借助特制的文件利用该漏洞执行代码或造成拒绝服务(基于堆的缓冲区越边界读取)。
|参考资料

来源:CONFIRM
链接:http://hg.code.sf.net/p/graphicsmagick/code/rev/a9c425688397
来源:CONFIRM
链接:https://sourceforge.net/p/graphicsmagick/bugs/521/