ws模块安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1132386 漏洞类型
发布时间 2017-10-31 更新时间 2018-06-01
CVE编号 CVE-2016-10518 CNNVD-ID CNNVD-201710-1249
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201710-1249
|漏洞详情
wsmodule是一款Node.jsWebSocket服务器的实现。ws模块1.0.0之前版本中的ping功能存在安全漏洞。攻击者可利用该漏洞使ws向服务器发送已被分配使用的缓冲区中的内容,泄露敏感信息。
|参考资料

来源:gist.github.com
链接:https://gist.github.com/c0nrad/e92005446c480707a74a
来源:github.com
链接:https://github.com/websockets/ws/releases/tag/1.0.1
来源:nodesecurity.io
链接:https://nodesecurity.io/advisories/67