LibOFX 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1133563 漏洞类型 缓冲区错误
发布时间 2017-09-29 更新时间 2019-10-23
CVE编号 CVE-2017-14731 CNNVD-ID CNNVD-201709-1156
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201709-1156
|漏洞详情
LibOFX是一款允许程序支持OFX(财务数据双向交换)命令响应的库。 LibOFX 0.9.12版本中的ofx_preproc.cpp文件的ofx_proc_file存在安全漏洞。远程攻击者可借助特制的文件利用该漏洞造成拒绝服务(基于堆的缓冲区越边界读取和应用程序崩溃)。
|参考资料

来源:MISC
链接:https://github.com/libofx/libofx/issues/10