Bento4 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1133736 漏洞类型 缓冲区错误
发布时间 2017-09-27 更新时间 2019-10-23
CVE编号 CVE-2017-14639 CNNVD-ID CNNVD-201709-1004
漏洞平台 N/A CVSS评分 6.8
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201709-1004
|漏洞详情
Bento4是一款用于读写MP4文件的开源的C++库。 Bento4 1.5.0-617版本中的Core/Ap4SampleEntry.cpp文件的AP4_VisualSampleEntry::ReadFields存在安全漏洞,该漏洞源于程序使用了错误的字符数据类型。攻击者可利用该漏洞造成拒绝服务(基于栈的缓冲区下溢、越边界写入和应用程序崩溃)。
|参考资料

来源:MISC
链接:https://blogs.gentoo.org/ago/2017/09/14/bento4-stack-based-buffer-underflow-in-ap4_visualsampleentryreadfields-ap4sampleentry-cpp/
来源:MISC
链接:https://github.com/axiomatic-systems/Bento4/commit/03d1222ab9c2ce779cdf01bdb96cdd69cbdcfeda
来源:MISC
链接:https://github.com/axiomatic-systems/Bento4/issues/190