ZenCart 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1135902 漏洞类型 代码注入
发布时间 2017-07-28 更新时间 2017-07-28
CVE编号 CVE-2017-11675 CNNVD-ID CNNVD-201707-1419
漏洞平台 N/A CVSS评分 6.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201707-1419
|漏洞详情
ZenCart是ZenCart团队开发的一套开源的购物车系统,它主要用于建立网上商店,可支持多种付款方式、多语言选择、网上商城批量更新等。ZenCart1.5.5e版本中的admin_dir/includes/classes/AdminRequestSanitizer.php文件的‘traverseStrictSanitize’函数存在安全漏洞,该漏洞源于程序没有正确的处理密钥字符串。远程攻击者可通过向‘admin_namearray’参数中的无效数组索引输入代码,并将参数发送到admin_dir/login.php文件利用该漏洞执行任意PHP代码。
|参考资料

来源:MISC
链接:https://github.com/imp0wd3r/vuln-papers/tree/master/zencart-155e-auth-rce