shoco API 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1136246 漏洞类型
发布时间 2017-07-25 更新时间 2017-07-25
CVE编号 CVE-2017-11367 CNNVD-ID CNNVD-201707-704
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201707-704
|漏洞详情
shoco是一个用于字符串压缩的C语言库。API是其中的一个编程接口。shoco2017-07-17及之前的版本中的API的‘shoco_decompress’函数存在安全漏洞。远程攻击者可借助畸形的压缩数据利用该漏洞造成拒绝服务(缓冲区越边界读取和应用程序崩溃)。
|参考资料

来源:MISC
链接:https://github.com/Ed-von-Schleck/shoco/issues/28