PoDoFo 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1139337 漏洞类型 缓冲区错误
发布时间 2017-04-30 更新时间 2019-10-23
CVE编号 CVE-2017-8378 CNNVD-ID CNNVD-201705-039
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201705-039
|漏洞详情
PoDoFo是一个开源的、使用C++编写的PDF文件格式的库。 PoDoFo 0.9.5版本中的base/PdfParser.cpp文件中的‘PdfParser::ReadObjects’函数存在基于堆的缓冲区溢出漏洞。远程攻击者可利用该漏洞造成拒绝服务(应用程序崩溃)。
|参考资料

来源:MISC
链接:https://github.com/xiangxiaobo/poc_and_report/tree/master/podofo_heapoverflow_PdfParser.ReadObjects