PoDoFo 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1140735 漏洞类型 缓冲区错误
发布时间 2017-03-31 更新时间 2019-10-23
CVE编号 CVE-2017-7379 CNNVD-ID CNNVD-201704-016
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201704-016
|漏洞详情
PoDoFo是一个开源的、使用C++编写的PDF文件格式的库。 PoDoFo 0.9.5版本中的PdfEncoding.cpp文件的‘PoDoFo::PdfSimpleEncoding::ConvertToEncoding’函数存在安全漏洞。远程攻击者可借助特制的PDF文档利用该漏洞造成拒绝服务(基于堆的缓冲区越边界读取和应用程序崩溃)。
|参考资料

来源:MISC
链接:https://blogs.gentoo.org/ago/2017/03/31/podofo-heap-based-buffer-overflow-in-podofopdfsimpleencodingconverttoencoding-pdfencoding-cpp