Gstreamer Base Plug-ins插件输入验证漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1142271 漏洞类型 输入验证错误
发布时间 2017-02-14 更新时间 2019-10-23
CVE编号 CVE-2017-5839 CNNVD-ID CNNVD-201702-359
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201702-359
|漏洞详情
GStreamer是一个用于构建媒体处理组件的图形库。Base Plug-ins是其中的一个用于维护的GStreamer插件的集合。 Gstreamer 1.10.3之前的版本中的Base Plug-ins插件的gst-libs/gst/riff/riff-media.c文件的‘gst_riff_create_audio_caps’函数存在安全漏洞,该漏洞源于程序没有正确的限制递归。远程攻击者可利用该漏洞造成拒绝服务(栈溢出和崩溃)。
|参考资料

来源:MLIST
链接:http://www.openwall.com/lists/oss-security/2017/02/02/9
来源:BID
链接:http://www.securityfocus.com/bid/96001
来源:gstreamer.freedesktop.org
链接:https://gstreamer.freedesktop.org/releases/1.10/#1.10.3
来源:MLIST
链接:http://www.openwall.com/lists/oss-security/2017/02/01/7
来源:bugzilla.gnome.org
链接:https://bugzilla.gnome.org/show_bug.cgi?id=777265