Squid HTTP Caching Proxy 缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1149035 漏洞类型 缓冲区错误
发布时间 2016-04-22 更新时间 2019-12-30
CVE编号 CVE-2016-4051 CNNVD-ID CNNVD-201604-517
漏洞平台 N/A CVSS评分 6.8
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201604-517
|漏洞详情
Squid(全称Squid Cache)是一套代理服务器和Web缓存服务器软件。该软件提供缓存万维网、过滤流量、代理上网等功能。 Squid的cachemgr.cgi文件中存在缓冲区溢出漏洞。远程攻击者可借助管理报告中特制的数据利用该漏洞造成拒绝服务或执行任意代码。以下版本受到影响:Squid 2.x版本,3.5.17之前3.x版本,4.0.9之前4.x版本。
|参考资料

来源:www.squid-cache.org
链接:http://www.squid-cache.org/Advisories/SQUID-2016_5.txt
来源:MLIST
链接:http://www.openwall.com/lists/oss-security/2016/04/20/9
来源:MLIST
链接:http://www.openwall.com/lists/oss-security/2016/04/20/6
来源:SECTRACK
链接:http://www.securitytracker.com/id/1035646