Web Reference Database和bleeding-edge 跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1152696 漏洞类型 跨站脚本
发布时间 2015-09-30 更新时间 2015-09-30
CVE编号 CVE-2015-6010 CNNVD-ID CNNVD-201509-561
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201509-561
|漏洞详情
WebReferenceDatabase(又名refbase)是refbase社区所研发的一款基于Web提供搜索工具和自动生成索引对科学文献进行管理的多用户界面产品。bleeding-edge是其中的一个下载版本。WebReferenceDatabase0.9.6及之前版本和bleeding-edge2015-01-08之前版本中存在跨站脚本漏洞,该漏洞源于error.php脚本没有充分过滤‘errorNo’和‘errorMsg’参数;duplicate_manager.php脚本没有充分过滤‘viewType’参数;query_manager.php脚本没有充分过滤多个参数(queryAction,displayType,citeOrder,sqlQuery,showQuery,showLinks,showRows,queryID);import.php脚本没有充分过滤‘sourceText’和‘sourceIDs’参数;modify.php脚本没有充分过滤‘typeName’和‘fileName’参数。远程攻击者可利用该漏洞注入任意Web脚本或HTML。
|参考资料

来源:US-CERTVulnerabilityNote:CERT-VN
链接:http://www.kb.cert.org/vuls/id/374092