eGroupware phpgwapi/inc/common_functions_inc.php 跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1170161 漏洞类型 跨站脚本
发布时间 2012-11-23 更新时间 2012-11-23
CVE编号 CVE-2012-2211 CNNVD-ID CNNVD-201211-439
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
https://cxsecurity.com/issue/WLB-2012040057
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201211-439
|漏洞详情
StyliteEGroupware是德国Stylite公司的一套基于PHP的团队协作软件。该软件包括电子邮件(IMAP/POP3)、通讯录、文档管理、书签等模块。eGroupware1.8.004.20120405之前版本中的phpgwapi/inc/common_functions_inc.php中存在跨站脚本漏洞。远程攻击者利用该漏洞通过‘menuaction’参数传送到etemplate/process_exec.php脚本,注入任意web脚本或HTML。
|漏洞EXP
Egroupware v1.8.002 (process_exec.php) Reflected Cross-Site Scripting (XSS)
Google Dork: inurl:etemplate/process_exec.php
Title: Egroupware v1.8.002 (process_exec.php) Remote XSS Vulnerability
Type: Remote
Author: Marcos Garcia
Severity: Medium  CVSS: 5 (AV:N/AC:L/Au:N/C:N/I:P/A:N)
Impact: Direct execution of arbitrary code in the context of Webserver user.
Release Date: 05.04.2012
Release mode: Coordinated release

Summary
=======

EGroupware is free open source groupware software intended for
businesses from small to enterprises. Its primary functions allow
users to manage contacts, appointments, projects and to-do lists.

Description
===========

A reflected Cross Site Scripting vulnerability was found in
EGroupware, because the application fails to sanitize user-supplied
input. The vulnerability can be triggered by any user.

--------------------------------------------------------------------------------

Detecting vulnerabilities
- /var/www/egroupware/etemplate:13
list($app) = explode('.',$_GET['menuaction']);

--------------------------------------------------------------------------------

Vendor
======

Egroupware - http://www.egroupware.org/


Affected Version
================

1.8.002

PoC
===
- /var/www/egroupware/etemplate:13
list($app) = explode('.',$_GET['menuaction']);

Attack: menuaction=[XSS] (GET)
http://host/egroupware/etemplate/process_exec.php?menuaction=TEST<script>alert(123)</script>


Credits
=======

Vulnerability discovered by Marcos Garcia (@artsweb).

Solution
========

Upgrade to Egroupware v1.8.004 (http://www.egroupware.org)

Vendor Status
=============

[24.03.2012] Vulnerability discovered.
[24.03.2012] Vendor informed.
[29.03.2012] Asked vendor for status.
[29.03.2012] Vendor replied.
[01.04.2012] Vendor reveals patch release date.
[05.04.2012] Public advisory.

Changelog
=========

[05.04.2012] - Initial release
|参考资料

来源:www.egroupware.org
链接:http://www.egroupware.org/changelog
来源:SECUNIA
名称:48703
链接:http://secunia.com/advisories/48703
来源:packetstormsecurity.org
链接:http://packetstormsecurity.org/files/111626/egroupware-xss.txt