RubyInstaller 不安全文件系统权限漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1170742 漏洞类型 权限许可和访问控制
发布时间 2012-10-11 更新时间 2013-09-09
CVE编号 CVE-2012-5380 CNNVD-ID CNNVD-201210-192
漏洞平台 N/A CVSS评分 6.0
|漏洞来源
https://www.securityfocus.com/bid/55885
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201210-192
|漏洞详情
RubyInstaller是一个在Windows下的安装程序,用来安装Ruby语言的开发工具和运行环境支持。RubyInstaller中存在漏洞。可被恶意本地攻击者利用以提升的权限执行某些操作。该漏洞源于应用程序在安装目录设置不安全文件系统权限。攻击者可利用该漏洞以其他用户的权限重写文件(如:C:\Ruby193\bin)并执行程序。1.9.3-p194版本中存在漏洞,其他版本也可能受到影响。
|参考资料

来源:SECUNIA
名称:50940
链接:http://secunia.com/advisories/50940