Moodle ‘lib/formslib.php’输入验证漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1172222 漏洞类型 输入验证
发布时间 2012-07-17 更新时间 2012-07-17
CVE编号 CVE-2012-0801 CNNVD-ID CNNVD-201207-262
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
https://www.securityfocus.com/bid/78287
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201207-262
|漏洞详情
Moodle是澳大利亚马丁-多基马(MartinDougiamas)博士开发的一套免费、开源的电子学习软件平台,也称课程管理系统、学习管理系统或虚拟学习环境。Moodle2.1.4之前的2.1.x版本和2.2.1之前的2.2.x版本中的lib/formslib.php中存在漏洞,该漏洞源于未正确处理表单元素的多个实例。远程攻击者可利用该漏洞产生未明影响和远程攻击向量。
|受影响的产品
Moodle Moodle 2.1.2 Moodle Moodle 2.2 Moodle Moodle 2.1.3 Moodle Moodle 2.1.1 Moodle Moodle 2.1
|参考资料

来源:git.moodle.org
链接:http://git.moodle.org/gw?p=moodle.git;a=commit;h=51070abc78b9e1db1db9a44855e8623b22bebd48
来源:bugzilla.redhat.com
链接:https://bugzilla.redhat.com/show_bug.cgi?id=783532
来源:moodle.org
链接:http://moodle.org/mod/forum/discuss.php?d=194020