Moodle ‘moodle_enrol_external:role_assign’函数权限许可和访问控制漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1172278 漏洞类型 权限许可和访问控制
发布时间 2012-07-16 更新时间 2012-07-16
CVE编号 CVE-2011-4295 CNNVD-ID CNNVD-201207-217
漏洞平台 N/A CVSS评分 6.5
|漏洞来源
https://www.securityfocus.com/bid/78393
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201207-217
|漏洞详情
Moodle是澳大利亚马丁-多基马(MartinDougiamas)博士开发的一套免费、开源的电子学习软件平台,也称课程管理系统、学习管理系统或虚拟学习环境。Moodle2.0.4之前的2.0.x版本和2.1.1之前的2.1.x版本中的enrol/externallib.php中的moodle_enrol_external:role_assign函数中存在漏洞,该漏洞源于未对授权校验。远程攻击者可利用该漏洞通过角色分配获取特权。
|受影响的产品
Moodle Moodle 2.0.3 Moodle Moodle 2.1 Moodle Moodle 2.0.2 Moodle Moodle 2.0.1 Moodle Moodle 2.0
|参考资料

来源:git.moodle.org
链接:http://git.moodle.org/gw?p=moodle.git;a=commit;h=d20f655d59cd486fd9b3a26ad353af13daafd1d3
来源:MLIST
名称:[oss-security]20111113Re:Fwd:DSA2338-1moodlesecurityupdate
链接:http://openwall.com/lists/oss-security/2011/11/14/1
来源:moodle.org
链接:http://moodle.org/mod/forum/discuss.php?d=182738