Python ‘list_directory’函数跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1172488 漏洞类型 跨站脚本
发布时间 2012-06-27 更新时间 2012-06-27
CVE编号 CVE-2012-2639 CNNVD-ID CNNVD-201206-454
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201206-454
|漏洞详情
Python是Python软件基金会的一套开源的、面向对象的程序设计语言。该语言具有可扩展、支持模块和包、支持多种平台等特点。Python2.5.6c1之前的版本、2.6.7rc2之前的2.6.x版本、2.7.2之前的2.7.x版本中的SimpleHTTPServer中的Lib/SimpleHTTPServer.py中的list_directory函数中存在漏洞,该漏洞源于在Content-TypeHTTP头中未放置charset参数。远程攻击者可利用该漏洞通过UTF-7编码对InternetExplorer7进行跨站脚本(XSS)攻击。
|参考资料

来源:JVNDB
名称:JVNDB-2012-000063
链接:http://jvndb.jvn.jp/jvndb/JVNDB-2012-000063
来源:JVN
名称:JVN#51176027
链接:http://jvn.jp/en/jp/JVN51176027/index.html
来源:bugs.python.org
链接:http://bugs.python.org/issue11442