WordPress ‘Login With Ajax’ 插件跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1172805 漏洞类型 跨站脚本
发布时间 2012-05-23 更新时间 2012-05-23
CVE编号 CVE-2012-2759 CNNVD-ID CNNVD-201205-393
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201205-393
|漏洞详情
WordPress是WordPress软件基金会的一套使用PHP语言开发的博客平台。该平台支持在PHP和MySQL的服务器上架设个人博客网站。WordPress的LoginWithAjax(也称login-with-ajax)插件3.0.4.1之前版本中的login-with-ajax.php中存在跨站脚本漏洞。远程攻击者可利用该漏洞借助传送至wp-login.php的lostpassword操作的callback参数注入任意web脚本或者HTML。
|参考资料

来源:www.secureworks.com
链接:http://www.secureworks.com/research/advisories/SWRX-2012-003/
来源:wordpress.org
链接:http://wordpress.org/extend/plugins/login-with-ajax/changelog/
来源:plugins.trac.wordpress.org
链接:http://plugins.trac.wordpress.org/changeset/541069