Apache HTTP Server ‘LD_LIBRARY_PATH’ 权限许可和访问控制漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1173169 漏洞类型 权限许可和访问控制
发布时间 2012-04-17 更新时间 2013-09-21
CVE编号 CVE-2012-0883 CNNVD-ID CNNVD-201204-359
漏洞平台 N/A CVSS评分 6.9
|漏洞来源
https://www.securityfocus.com/bid/53046
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201204-359
|漏洞详情
ApacheHTTPServer是流行的开源WEB服务器程序,可使用在Unix和Windows操作系统下。ApacheHTTPServer2.4.2之前版本中的envvars(也称envvars-std)中存在漏洞,该漏洞源于在LD_LIBRARY_PATH中放置了一个零长度的目录名。本地用户在执行apachectl时,可借助在当前工作的目录中的特洛伊木马DSO,获取权限。
|受影响的产品
Xerox FreeFlow Print Server (FFPS) 73.C0.41 Xerox FreeFlow Print Server (FFPS) 73.B3.61 Sun Solaris 11 Sun Solaris 10 Mandriva Linux Mandrake 2011 x86_64 Mandriva Linux M
|参考资料

来源:svn.apache.org
链接:http://svn.apache.org/viewvc?view=revision&revision=1296428
来源:www.apache.org
链接:http://www.apache.org/dist/httpd/Announcement2.4.html
来源:MLIST
名称:[dev]20120417[ANNOUNCEMENT]ApacheHTTPServer2.4.2Released
链接:http://article.gmane.org/gmane.comp.apache.devel/48158
来源:BID
名称:53046
链接:http://www.securityfocus.com/bid/53046
来源:NSFOCUS
名称:21001
链接:http://www.nsfocus.net/vulndb/21001