libarchive 缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1173270 漏洞类型 缓冲区溢出
发布时间 2012-04-17 更新时间 2012-04-18
CVE编号 CVE-2010-4666 CNNVD-ID CNNVD-201204-294
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201204-294
|漏洞详情
libarchive3.0预发布代码中存在缓冲区溢出漏洞,该漏洞源于在读取LZX压缩数据中的Huffman编码数据时未正确处理。远程攻击者可利用该漏洞借助特制CAB文件导致拒绝服务(应用程序崩溃)或者可能产生其他未明影响。
|参考资料

来源:bugzilla.redhat.com
链接:https://bugzilla.redhat.com/show_bug.cgi?id=705849
来源:code.google.com
链接:http://code.google.com/p/libarchive/source/detail?r=2842