Linux Kernel Block Layer多个整数溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1177346 漏洞类型 输入验证错误
发布时间 2011-01-04 更新时间 2020-08-17
CVE编号 CVE-2010-4162 CNNVD-ID CNNVD-201101-008
漏洞平台 N/A CVSS评分 4.7
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201101-008
|漏洞详情
Linux kernel是美国Linux基金会发布的开源操作系统Linux所使用的内核。NFSv4 implementation是其中的一个分布式文件系统协议。 Linux kernel 2.6.36.2之前版本中的fs/bio.c文件中存在多个整数溢出漏洞。本地用户可以借助对SCSI设备的特制输入输出控制导致拒绝服务(系统崩溃)。
|参考资料

来源:bugzilla.redhat.com
链接:https://bugzilla.redhat.com/show_bug.cgi?id=652529
来源:www.kernel.org
链接:http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.36.2
来源:MLIST
名称:[oss-security]20101112Re:CVErequest:kernel:MultipleDoSissuesinblocklayer
链接:http://openwall.com/lists/oss-security/2010/11/12/2
来源:MLIST
名称:[oss-security]20101110CVErequest:kernel:MultipleDoSissuesinblocklayer
链接:http://openwall.com/lists/oss-security/2010/11/10/18
来源:git.kernel.org
链接:http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=cb4644cac4a2797afc847e6c92736664d4b0ea34