Openswan programs/pluto/xauth.c文件缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1178279 漏洞类型 代码注入
发布时间 2010-09-29 更新时间 2019-07-30
CVE编号 CVE-2010-3308 CNNVD-ID CNNVD-201010-013
漏洞平台 N/A CVSS评分 6.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201010-013
|漏洞详情
Xelerance Openswan是加拿大Xelerance公司的一个基于FreeS/WAN项目的用于Linux系统下的IPSEC实现,它主要用于保证数据传输中的安全性、完整性等问题。 Openswan 2.6.26至2.6.28版本中的客户端中的programs/pluto/xauth.c文件存在缓冲区溢出漏洞。远程认证网关可以借助超长cisco_banner (又名server_banner)域执行任意代码或者导致拒绝服务。
|参考资料

来源:www.openswan.org
链接:http://www.openswan.org/download/CVE-2010-3308/openswan-2.6.26-2.6.28-CVE-2010-330x.patch
来源:VUPEN
名称:ADV-2010-2526
链接:http://www.vupen.com/english/advisories/2010/2526
来源:BID
名称:43588
链接:http://www.securityfocus.com/bid/43588
来源:www.openswan.org
链接:http://www.openswan.org/download/CVE-2010-3308/CVE-2010-3308.txt
来源:NSFOCUS
名称:15827
链接:http://www.nsfocus.net/vulndb/15827