PHP JSON_parser函数 拒绝服务漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1183139 漏洞类型 其他
发布时间 2009-04-08 更新时间 2009-06-09
CVE编号 CVE-2009-1271 CNNVD-ID CNNVD-200904-181
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200904-181
|漏洞详情
PHP5.2.9之前的5.2.x版本中的JSON_parser函数(ext/json/JSON_parser.c)允许远程攻击者借助一个到json_decodeAPI函数的畸形字符串,引起拒绝服务攻击(分割错误)。
|参考资料

来源:FEDORA
名称:FEDORA-2009-3848
链接:https://www.redhat.com/archives/fedora-package-announce/2009-May/msg01465.html
来源:FEDORA
名称:FEDORA-2009-3768
链接:https://www.redhat.com/archives/fedora-package-announce/2009-May/msg01451.html
来源:UBUNTU
名称:USN-761-1
链接:http://www.ubuntulinux.org/support/documentation/usn/usn-761-1
来源:UBUNTU
名称:USN-761-2
链接:http://www.ubuntu.com/usn/USN-761-2
来源:REDHAT
名称:RHSA-2009:0350
链接:http://www.redhat.com/support/errata/RHSA-2009-0350.html
来源:www.php.net
链接:http://www.php.net/releases/5_2_9.php
来源:MLIST
名称:[oss-security]20090401CVErequest:PHP5.2.9
链接:http://www.openwall.com/lists/oss-security/2009/04/01/9
来源:MANDRIVA
名称:MDVSA-2009:090
链接:http://www.mandriva.com/security/advisories?name=MDVSA-2009:090
来源:DEBIAN
名称:DSA-1789
链接:http://www.debian.org/security/2009/dsa-1789
来源:DEBIAN
名称:DSA-1775
链接:http://www.debian.org/security/2009/dsa-1775
来源:support.apple.com
链接:http://support.apple.com/kb/HT3865
来源:SECUNIA
名称:36701
链接:http://secunia.com/advisories/36701
来源:SECUNIA