Ghostscript 多个输入验证漏洞和整数溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1183365 漏洞类型 数字错误
发布时间 2009-03-19 更新时间 2009-06-13
CVE编号 CVE-2009-0792 CNNVD-ID CNNVD-200904-270
漏洞平台 N/A CVSS评分 9.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200904-270
|漏洞详情
Ghostscript是用于显示PostScript文件或向非PostScript打印机打印这些文件的程序。Ghostscript的国际色彩联盟格式库(icclib)中存在多个可导致堆溢出的整数溢出,以及多个不充分输入验证错误。攻击者可以使用特制的ICC配置文件创建嵌入了图形的恶意PostScript或PDF文件,如果受害用户打开了该文件就会导致Ghostscript崩溃或执行任意代码。
|参考资料

来源:FEDORA
名称:FEDORA-2009-3710
链接:https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00461.html
来源:FEDORA
名称:FEDORA-2009-3709
链接:https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00460.html
来源:FEDORA
名称:FEDORA-2009-3435
链接:https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00217.html
来源:FEDORA
名称:FEDORA-2009-3430
链接:https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00211.html
来源:bugzilla.redhat.com
链接:https://bugzilla.redhat.com/show_bug.cgi?id=491853
来源:XF
名称:ghostscript-icc-bo(50381)
链接:http://xforce.iss.net/xforce/xfdb/50381
来源:VUPEN
名称:ADV-2009-1708
链接:http://www.vupen.com/english/advisories/2009/1708
来源:UBUNTU
名称:USN-757-1
链接:http://www.ubuntulinux.org/support/documentation/usn/usn-757-1
来源:BUGTRAQ
名称:20090417rPSA-2009-0060-1ghostscript
链接:http://www.securityfocus.com/archive/1/archive/1/502757/100/0/threaded
来源:REDHAT
名称:RHSA-2009:0421
链接:http://www.redhat.com/support/errata/RHSA-2009-0421.html
来源:REDHA