Xlinesoft PHPRunner 脚本UserView_list.php SQL注入漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1183367 漏洞类型 信任管理
发布时间 2009-03-19 更新时间 2009-03-19
CVE编号 CVE-2009-0964 CNNVD-ID CNNVD-200903-321
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
https://www.securityfocus.com/bid/80633
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200903-321
|漏洞详情
PHPRunner是一款PHP网页制作工具,可以生成读写MySql数据库的PHP网页。PHPRunner的UserView_list.php模块中没有正确地验证对SearchField参数所传送的输入便在SQL查询中使用,远程攻击者可以通过提交恶意查询请求执行SQL注入攻击,完全入侵数据库系统。
|受影响的产品
XLineSoft PHPRunner 4.2 XLineSoft PHPRunner 3.1
|参考资料

来源:XF
名称:phprunner-userview-information-disclosure(49279)
链接:http://xforce.iss.net/xforce/xfdb/49279
来源:VUPEN
名称:ADV-2009-0750
链接:http://www.vupen.com/english/advisories/2009/0750
来源:BUGTRAQ
名称:20090317PHPRunnerSQLInjection
链接:http://www.securityfocus.com/archive/1/archive/1/501894/100/0/threaded
来源:MILW0RM
名称:8226
链接:http://www.milw0rm.com/exploits/8226
来源:MISC
链接:http://www.bugreport.ir/index_63.htm
来源:OSVDB
名称:52804
链接:http://osvdb.org/52804