Ravenphpscripts Raven Web Services RavenNuke'你的账户'模块任意代码执行漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1183598 漏洞类型 代码注入
发布时间 2009-02-22 更新时间 2009-02-22
CVE编号 CVE-2009-0677 CNNVD-ID CNNVD-200902-496
漏洞平台 N/A CVSS评分 6.5
|漏洞来源
https://www.securityfocus.com/bid/82985
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200902-496
|漏洞详情
RavenNuke是基于PHP和MySQL的自动新闻发布和内容管理系统。RavenWebServicesRavenNuke的“你的账户”模块中的“avatarlist.php”至“modules.php”存在代码执行漏洞。如同少许样品阵列指明的那样,preg_replace函数使用eval交换处理少许复位阵列中的PHP序列,远程攻击者可以利用此PHP序列执行任意代码。
|受影响的产品
Ravenphpscripts Ravennuke 2.30
|参考资料

来源:XF
名称:ravennuke-avatarlist-code-execution(48789)
链接:http://xforce.iss.net/xforce/xfdb/48789
来源:MISC
链接:http://www.waraxe.us/advisory-72.html
来源:BID
名称:33787
链接:http://www.securityfocus.com/bid/33787
来源:BUGTRAQ
名称:20090216[waraxe-2009-SA#072]-MultipleVulnerabilitiesinRavenNuke2.3.0
链接:http://www.securityfocus.com/archive/1/archive/1/500988/100/0/threaded
来源:OSVDB
名称:52007
链接:http://www.osvdb.org/52007
来源:MILW0RM
名称:8068
链接:http://www.milw0rm.com/exploits/8068
来源:SECUNIA
名称:33928
链接:http://secunia.com/advisories/33928
来源:ravenphpscripts.com
链接:http://ravenphpscripts.com/postt17156.html&sid=12d1201371612260a42fa846ebce7bad