IBM WebSphere应用服务器WSPolicy信息泄露漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1183653 漏洞类型 信息泄露
发布时间 2009-02-12 更新时间 2009-02-24
CVE编号 CVE-2009-0504 CNNVD-ID CNNVD-200902-372
漏洞平台 N/A CVSS评分 2.1
|漏洞来源
https://www.securityfocus.com/bid/33879
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200902-372
|漏洞详情
IBMWebsphere应用服务器以Java和Servlet引擎为基础,支持多种HTTP服务,可帮助用户完成从开发、发布到维护交互式的动态网站的所有工作。WebSphere应用服务器的WebServices组件没有正确地识别IDAssertion.isUsed绑定属性。如果在使用WebServices组件,且客户端使用ProviderOnly的WSPolicy,并且所使用的简单UserNameTokenpolicyset设置的com.ibm.wsspi.wssecurity.token/IDAssertion.isUsed绑定属性设置为true,WSPolicy就可能忽略这个设置,向SOAP消息中添加敏感信息,这样客户端就可以访问本不应发送的信息。
|受影响的产品
IBM Websphere Application Server 7.0
|参考资料

来源:www-01.ibm.com
链接:http://www-01.ibm.com/support/docview.wss?uid=swg27014463
来源:XF
名称:websphere-wspolicy-information-disclosure(48700)
链接:http://xforce.iss.net/xforce/xfdb/48700
来源:AIXAPAR
名称:PK73573
链接:http://www-1.ibm.com/support/docview.wss?uid=swg1PK73573