xrdp ‘xrdp/xrdp_bitmap.c’多个缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1184061 漏洞类型 缓冲区溢出
发布时间 2009-01-15 更新时间 2009-02-10
CVE编号 CVE-2008-5902 CNNVD-ID CNNVD-200901-172
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200901-172
|漏洞详情
xrdp是软件开发者JaySorg所研发的一款开源的远程桌面协议(RDP)服务器。xrdp0.4.1以及之前的版本的xrdp/xrdp_bitmap.c中的xrdp_bitmap_invalidate函数存在缓冲区溢出漏洞。远程攻击者可以借助一个特制的请求,执行任意的代码。
|参考资料

来源:MISC
链接:http://packetstormsecurity.org/0812-advisories/VA_VD_87_08_XRDP.pdf
来源:MLIST
名称:[oss-security]20090112CVErequest:xrdp
链接:http://openwall.com/lists/oss-security/2009/01/12/3
来源:SUSE
名称:SUSE-SR:2009:003
链接:http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00000.html