ZXID 函数OpenSSL DSA_verify 安全绕过漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1184151 漏洞类型 授权问题
发布时间 2009-01-07 更新时间 2009-02-12
CVE编号 CVE-2009-0051 CNNVD-ID CNNVD-200901-065
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200901-065
|漏洞详情
OpenSSL是OpenSSL团队开发的一个开源的能够实现安全套接层(SSLv2/v3)和安全传输层(TLSv1)协议的通用加密库,它支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。ZXID没有正确处理函数OpenSSLDSA_verify返回值,使系统存在安全绕过漏洞。远程攻击者可以通过为DSA和ECDSAkey伪造SSL/TLS签名绕过证书链表符合性检查。
|参考资料

来源:XF
名称:openssl-dsa-verify-security-bypass(47837)
链接:http://xforce.iss.net/xforce/xfdb/47837
来源:MISC
链接:http://www.ocert.org/advisories/ocert-2008-016.html