Belgian eID middleware函数OpenSSL EVP_VerifyFinal安全绕过漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1184153 漏洞类型 授权问题
发布时间 2009-01-07 更新时间 2009-03-13
CVE编号 CVE-2009-0049 CNNVD-ID CNNVD-200901-063
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200901-063
|漏洞详情
OpenSSL是OpenSSL团队开发的一个开源的能够实现安全套接层(SSLv2/v3)和安全传输层(TLSv1)协议的通用加密库,它支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。BelgianeIDmiddleware没有正确处理函数OpenSSLEVP_VerifyFinal返回值,使系统存在安全绕过漏洞。远程攻击者可以通过为DSA和ECDSAkey伪造SSL/TLS签名绕过证书链表符合性检查。
|参考资料

来源:MISC
链接:http://www.ocert.org/advisories/ocert-2008-016.html
来源:SECUNIA
名称:34029
链接:http://secunia.com/advisories/34029
来源:SUSE
名称:SUSE-SR:2009:005
链接:http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00000.html