NVIDIA Cg Toolkit 'nvidia-cg-toolkit-installer'任意文件重写漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1184577 漏洞类型 后置链接
发布时间 2008-08-11 更新时间 2008-11-22
CVE编号 CVE-2008-5144 CNNVD-ID CNNVD-200811-304
漏洞平台 N/A CVSS评分 6.9
|漏洞来源
https://www.securityfocus.com/bid/32411
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200811-304
|漏洞详情
NVIDIACgToolkit是NVIDIA开发的一个Cg2.0语言和实时运行库的编译器。NVIDIACgToolkitt中的nvidia-cg-toolkit-installer允许本地用户借助一个对/tmp/nvidia-cg-toolkit-manifest临时文件的symlink攻击,重写任意文件。
|受影响的产品
NVIDIA Cg Toolkit Installer NVIDIA Cg Toolkit Installer 2.0.15 Debian Linux 4.0 sparc Debian Linux 4.0 s/390 Debian Linux 4.0 powerpc Debian Linux 4.0 mipsel Debian Linux
|参考资料

来源:BID
名称:32411
链接:http://www.securityfocus.com/bid/32411
来源:MLIST
名称:[debian-devel]20080811Re:Possiblemassbugfiling:ThepossibilityofattackwiththehelpofsymlinksinsomeDebianpackages
链接:http://lists.debian.org/debian-devel/2008/08/msg00285.html