GNU Enscript 'psgen.c'栈溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1184865 漏洞类型 缓冲区溢出
发布时间 2008-10-22 更新时间 2009-02-26
CVE编号 CVE-2008-4306 CNNVD-ID CNNVD-200811-056
漏洞平台 N/A CVSS评分 9.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200811-056
|漏洞详情
GNUenscript是用于替换Adobeenscript程序的脚本。Enscript可将ASCII文件转换为PostScript并将生成的PostScript输出提供给指定的打印机。GNUenscriptsrc/psgen.c文件中的read_special_escape()函数存在栈溢出漏洞。如果用户通过-e选项启用了特殊转义处理的话,在转换恶意文件时就可能触发这个溢出,导致执行任意指令。
|参考资料

来源:FEDORA
名称:FEDORA-2008-9372
链接:https://www.redhat.com/archives/fedora-package-announce/2008-November/msg00040.html
来源:FEDORA
名称:FEDORA-2008-9351
链接:https://www.redhat.com/archives/fedora-package-announce/2008-November/msg00014.html
来源:UBUNTU
名称:USN-660-1
链接:http://www.ubuntu.com/usn/usn-660-1
来源:REDHAT
名称:RHSA-2008:1016
链接:http://www.redhat.com/support/errata/RHSA-2008-1016.html
来源:MANDRIVA
名称:MDVSA-2008:243
链接:http://www.mandriva.com/security/advisories?name=MDVSA-2008:243
来源:support.avaya.com
链接:http://support.avaya.com/elmodocs2/security/ASA-2008-504.htm
来源:GENTOO
名称:GLSA-200812-02
链接:http://security.gentoo.org/glsa/glsa-200812-02.xml
来源:SECUNIA
名称:33109
链接:http://secunia.com/advisories/33109
来源:SECUNIA
名称:32970
链接:http://secunia.com/advisories/32970
来源:SECUNIA
名称:32530
链接:http://secunia.com/advisories/32530
来源:SECUNIA
名称:32521
链接:http://secunia.com/advisories/32521
来源:OSVDB
名称:49569
链接:http://osvdb.org/49569
来源:SUSE
名称:SUSE-SR:2008:024
链接:http://lists.opensuse.org/opensuse-secur