GNU Emacs 'python.el' 代码执行漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1185251 漏洞类型 代码注入
发布时间 2008-09-05 更新时间 2009-02-23
CVE编号 CVE-2008-3949 CNNVD-ID CNNVD-200809-270
漏洞平台 N/A CVSS评分 7.2
|漏洞来源
https://www.securityfocus.com/bid/31052
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200809-270
|漏洞详情
在编辑一个Python文件时,当前工作目录的Emacs22.1和22.2importsPython脚本,本地用户可以通过一个特洛伊木马文件以执行任意代码。
|受影响的产品
S.u.S.E. openSUSE 11.0 S.u.S.E. openSUSE 10.3 S.u.S.E. openSUSE 10.2 Pardus Linux 2008 0 Pardus Linux 2007 0 Mandriva Linux Mandrake 2008.1 x86_64 Mandri
|参考资料

来源:bugzilla.novell.com
链接:https://bugzilla.novell.com/show_bug.cgi?id=424340
来源:XF
名称:emacs-python-code-execution(45021)
链接:http://xforce.iss.net/xforce/xfdb/45021
来源:BID
名称:31052
链接:http://www.securityfocus.com/bid/31052
来源:MANDRIVA
名称:MDVSA-2008:216
链接:http://www.mandriva.com/security/advisories?name=MDVSA-2008:216
来源:GENTOO
名称:GLSA-200902-06
链接:http://security.gentoo.org/glsa/glsa-200902-06.xml
来源:SECUNIA
名称:34004
链接:http://secunia.com/advisories/34004
来源:SECUNIA
名称:31982
链接:http://secunia.com/advisories/31982
来源:SUSE
名称:SUSE-SR:2008:018
链接:http://lists.opensuse.org/opensuse-security-announce/2008-09/msg00004.html
来源:MLIST
名称:[emacs-devel]20080905VulnerabilityinEmacspythonintegration
链接:http://lists.gnu.org/archive/html/emacs-devel/2008-09/msg00215.html