sanitize-html 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1185635 漏洞类型 跨站脚本
发布时间 2018-06-04 更新时间 2019-10-17
CVE编号 CVE-2017-16017 CNNVD-ID CNNVD-201806-193
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201806-193
|漏洞详情
Sanitize-html是一个用于清理用户提交的HTML的工具。 Sanitize-html 1.2.2及之前版本中存在跨站脚本漏洞。远程攻击者可通过利用该漏洞注入任意的Web脚本或HTML。
|参考资料
resource:
hyperlink:https://github.com/punkave/sanitize-html/issues/19
resource:
hyperlink:https://github.com/punkave/sanitize-html/pull/20
resource:
hyperlink:https://nodesecurity.io/advisories/155